服务器代维,美国高防cdn,服务器安全维护 -
吴天是个专业的运维工作者,一个设计爱好者的博客,也是所有草根站长学习升级,设计爱好者互相学习的交流平台!

shopnc 2.4多用户商城环境要求

            最近有用户向服务器代维中心咨询,SHOPNC 2.4到底是用PHP5.2还是5.3,客户安装了PHP5.3打不开网站,显示ZEND解析错误.百度了下得出如下答案:

主流WEB服务器(如Apache、Nginx、IIS等)

PHP5.2、PHP5.3- Zend Optimizer3.X(适用PHP5.2)或 Zend Guard Loader(适用PHP5.3)- MySQL 5.0 及以上的数据库环境



            但事实上,经过服务器代维员的试验,SHOPNC 2.4是不支持PHP5.3的,因为SHOPNC是用Zend Optimizer加密的,服务器安装的是Zend Guard Loader,自然,就解析不了Zend Optimizer加密.所以正确的环境要求如下:

Apache、Nginx、IIS

PHP5.2

Zend Optimizer3.3.3

MySQL 5.0 及以上的数据库服务器环境.


标签:
分类:最新服务器技术| 发布:服务器代维| 查看: | 发表时间:2014-5-9
原创文章如转载,请注明:转载自服务器代维,美国高防cdn,服务器安全维护 http://www.3306safe.com/
本文链接:http://www.3306safe.com/html/261.html

已经有 ( 1 ) 位网友发表了评论,你也评一评吧!

1#f
查shopnc的问题的时候搜索到了这篇。感谢博主给我指明了方向,虽然你说的还是错的。
检查试验后,2.4是可以并且完完全全支持zend guard loader的,反而是在5.2的optimizer下可能有一些问题,并且这些原因多次复现。
而且从原理上来说,支持zend optimizer和zend guard loader一脉相承,本来就应该是完全兼容的。
shopc是个傻逼程序,能搜索到的资料很少,我也是今天解决问题遇到不少坑,博主这还是给了我一些启发的,特地上来回复一下,也许以后别的人看到的时候能有更多的启示。

不过还需要提醒的是,在5.3下,opcache的开启反而有可能有影响。总而言之,这是个傻逼程序,能绕多远绕多远。
我也做了六七年代维了,有机会希望和博主多交流。别人说文人相轻,但这行是可以共同提高的。
http://www.deyn.org2014-12-22 13:08:10 回复
Design By 服务器安全 | Power By 服务器代维